re = /[\*]{1,2}([a-z ]*)[\*]{1,2}/
str = 'the *big* brown fox *jumps over* the *lazy* **dog**'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end