import Foundation
let pattern = #"^([^\d\n]+(?:\d+[^\d\n]*)?)(?: |$)(?:(\d+|SN\b) *([^\d\n]+\d+))?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AV 12 DE SETEMBRO 25 BLOCO 02
RUA JOSE ANTONIO 132 CS 05
AV CAXIAS 02 CASA 03
AV 11 DE NOVEMBRO 2032 CASA 4
RUA 05 DE OUTUBRO 25 CASA 02
RUA 15
AVENIDA 3 PODERES
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"no_logradouro:$1, nu_logradouro:$2, complemento:$3\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)