$re = '/(?s)(test)([^<>]*?)(attribute="one")(([^<>]*?)(?:(?!<\/test>).)*<importantTag>(?:(?!<\/test>|<\/importantTag>).)*<one>[^<>]*<\/one>[^<>]*<one>[^<>]*<\/one>(?:(?!<\/test>|<\/importantTag>).)*<\/importantTag>(?:(?!<\/test>).)*)<\/test>/';
$str = '<root>
<test attribute="one">
<unimportantTag>
<one>text</one>
</unimportantTag>
<importantTag>
<one>text</one>
<one>text</one>
</importantTag>
</test>
<test attribute="one">
<unimportantTag>
<one>text</one>
</unimportantTag>
<importantTag>
<one>text</one>
</importantTag>
</test>
</root>';
$subst = "$1$2attribute=\"replaced\"$4>$5</test>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;