const regex = /([a-zA-Z0-9]{13}(?:[-]{1}[A-Z]{1}){0,1})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9]{13}(?:[-]{1}[A-Z]{1}){0,1})', '')
const str = `246630183F316`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);