$re = '/c[^chugjug]*?h[^chugjug]*?u[^chugjug]*?g[^chugjug]*?j[^chugjug]*?u[^chugjug]*?g[^chugjug]*?/';
$str = 'chugjug
chug-jug';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);