$re = '/([a-z0-9]*[!@#\$%\*\(\)_\-:;\.]){3,}[a-z0-9]*/';
$str = 'a;a;a;a';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);