import Foundation
let pattern = #"http:\/\/example\.com\/foo(\/[\w]+\b)?[^\/]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://example.com/foo/apple
http://example.com/foo/bear
http://example.com/foo/cake
http://example.com/baa/apple
http://example.com/foo/apple/cake/bar/1
http://example.com/foo/bear/camel/bar/2
http://example.com/foo/bear/cake/bar/two
http://example.com/foo/bear/camel/tar/2
http://example.com/foo/bear/camel
http://example.com/foo/bear/camel/
http://example.com/foo/bear/camel/tar/2/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)