$re = '/^(?!.*(.)(?:.*\1){3,}).*$/m';
$str = '1a1a1a1a1
aaaa11111
2222aaa33a
sadsada';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);