package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(\d+)\b|([+=\\-])`)
var str = `12+3=15`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}