// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z0-9]\s+)|(\s+[a-zA-Z0-9])$").unwrap();
let string = "c 59 e5 04 d8 09 00 24 43 b8 d2 1a 08 00 45 00
00 30 61 7c 00 00 1d 06 99 4c ac 11 4 19 0a c
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}