re = /^(?:[+-]?([0-9]*[.])?[0-9]+,){3}[+-]?([0-9]*[.])?[0-9]+$/m
str = '20,-3,0,10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end