$re = '/Book\s*\K\d+(?:\s*-\s*\d+)?/m';
$str = 'Book 1 - abcd
Book 1 -
Book 1 - 2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);