const regex = /(\d{1,4}?[-.\s]?)*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{1,4}?[-.\\s]?)*', '')
const str = `01.01 0-205060604-505202
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}