use strict;
my $str = '
PATS_TEST,24151N073332,04/07/2016.09.53.45,TEST_START_TIME, ,4/7/2016 9:46:02 AM, ,PASS, ,15,NONE,0.01,0,, ,
';
my $regex = qr/^PATS_TEST,\s*[0-9A-Za-z_.]{1,50},\d+\/\d+\/\d+\s+\d+[:.]\d+[:.]\d+,[^,]+,[^,]*,[^,]*,[^,]*,[PFAI],[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*,[^,]*$/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}