import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w+) =.*\\n(?=((?!\\b\\1\\b)[^!])*(^\\1 =|\\Z))";
final String string = "a = 10\n"
+ "a * 3\n\n"
+ "foo = 8\n"
+ "2 - 1\n"
+ "b = 18\n\n"
+ "c = 10\n"
+ "d = 8\n"
+ "d = 4\n"
+ "cd = 72 \n"
+ "d / 6\n"
+ "d + 1\n\n"
+ "e = 1\n"
+ "e = 2\n"
+ "e + 1\n\n"
+ "FooBar1 = 0\n"
+ "Fuz__ = 8\n"
+ "Fuz__ / 1\n\n"
+ "f = 1\n"
+ "f + 1\n"
+ "f = 2\n"
+ "f + 1\n\n"
+ "g = 1\n"
+ "1 / 5 * 8 + 4";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}