using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?:[^)(]|\((?:[^)(]|\([^)(]*\))*\))*\)";
string input = @"stuff (remove(me)) bar (a(b(c)) (bar(baz))) foo";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}