$re = '/^(?!(?:.*?[A-Z]){4})/m';
$str = 'aAnnBccD#!
AAbbC
AbCdeFgHiJ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);