package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\(hd.,gpt)`)
var str = `(hd1,gpt3)/grub`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}