using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"help::[\r\n\t\f ]*(.*?)(?=[\r\n\t\f ]*?\*\/|[\r\n\t\f ]*?-->)";
string input = @"/* help::this is my comment */
<!-- help:: this is my other comment -->";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}