package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`U0591-U05C7`)
var str = `הֻסְמַק`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}