import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:[CDEFGAB](?:b|bb|m)*(?:\\#|\\#\\#|sus|maj|min|aug)*[\\d\\/]*(?:[CDEFGAB](?:b|bb|m)*(?:\\#|\\#\\#|sus|maj|min|aug)*[\\d\\/]*)*),?)+(?=\\s|$|(?:<.*>))(?![[:blank:]]\\w)";
final String string = "G,C,D\n"
+ "A,B,C\n"
+ "E,C,D";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}