using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\b[^><]*>(*SKIP)(*F)|{{[^}{]+}}";
string input = @"Lorem ipsum {{ var1 }} dolar epsum <a href=""{{ var2 }}"">solar</a> hello goodbye. {{var3}} var {{ var4 }}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}