import re
regex = re.compile(r"\bmazda(\d+)")
test_str = "mazda mazda6 mazda 6 mazda3 mazda2"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)