#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\/\/([^\/]+)((?:\/[^\/]+)*)\/([^\/]+)$"
Local $sString = "//AppManagement/Feature-PublishContent-XA-1526/Infrastructure/AppLibraryService/Scripts/AppLibrary.psm1" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")