package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s`)
var str = `fsdm
fmsdlfk m
fsdfsdf
fsd,fsdf
sd kla mdl`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}