re = /\$(\{?(\w+)\}?)(?:\.\$(\{?(\w+)\}?))?/
str = '$FIRSTVAR.${SECONDVAR}LITERAL
${firstvar}.${secondvar}literal
${firstvar}.literal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end