using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!SpecialBlah\b)\b\w+Blah\b";
string input = @"sdfsdBlah SpecialBlah sdlfsdfsdfBlah";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}