const regex = /-\d*.jpeg/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\d*.jpeg', '')
const str = `/imagename-101.jpeg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}