# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^\s*
(?:
(?P<date>
(?:[\[<\(]\s*)? # opening bracket
(?:
# date time
(?:
# date
(?:
(?: # matches mm-dd-yyyy mm-dd-yy mm-dd
\d{1,2}-\d{1,2}
(?:
-
(?:\d{4}|\d{2})
)?
)
|
(?: # matches mm/dd/yyyy mm/dd/yy mm/dd
\d{1,2}\/\d{1,2}
(?:
\/
(?:\d{4}|\d{2})
)?
)
)
\s+
# time
\d{1,2}:\d{2}
(?::\d{2})?
(?:
\s*
(?:AM|PM)
)?
)
|
# time date
(?:
# time
\d{1,2}:\d{2}
(?::\d{2})?
(?:
\s*
(?:AM|PM)
)?
\s+
# date
(?:
(?: # matches mm-dd-yyyy mm-dd-yy mm-dd
\d{1,2}-\d{1,2}
(?:
-
(?:\d{4}|\d{2})
)?
)
|
(?: # matches mm/dd/yyyy mm/dd/yy mm/dd
\d{1,2}\/\d{1,2}
(?:
\/
(?:\d{4}|\d{2})
)?
)
)
)
|
# time only
(?:
\d{1,2}:\d{2}
(?::\d{2})?
(?:
\s*
(?:AM|PM)
)?
)
)
(?:\s*[\)>\]])? # closing bracket
)
\s+
)?
(?P<name>
(?:
(?:<\s*[^\s:>]+\s*>) # match <Username>
|
(?:[^\s:]+:) # match Username:
)
)
\s+
(?P<message>.*)
$
"""
test_str = ("<11:54 PM> Sirenfal: Asdf\n"
"[11:54] <Sirenfal> Asdf\n"
"11:54 Sirenfal: Asdf\n"
"[1/1/06 11:54 AM] Sirenfal: asdf\n"
"<11:54> Asdf")
matches = re.finditer(regex, test_str, re.VERBOSE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.