re = /(?<=;|^)("?)([^;]*)\1(;|$)/mi
str = ';testvalue;"testvalue";"test "val"ue";test value;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end