import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([hale]*\\w*\\.?\\d*)([\\.\\/\\-_\\s]?)([stand]*)(\\d+)([a-z]*)";
final String string = "InnoTrans 16 Reinigung 23/705 Vorr./Tägl.\n"
+ "InnoTrans 16 Reinigung 17/113 Vorr./Tägl.\n"
+ "InnoTrans 16 Reinigung 26./141 Vorr./Tägl.\n"
+ "InnoTrans 16 Reinigung 6.2/507 Vorr./Tägl.\n"
+ "trans 4.1/412 vor u tä\n"
+ "Trans 16,23/606, Vor + tägl. Reinigung\n"
+ "Trans 16 10.2/300 Vor-, täglich\n"
+ "FUNK 16 Reinigung 14.1/124 Vorr./Tägl.\n"
+ "STORNO !!!InnoTrans 16 Reinigung 4.2/208a Vorr./Tägl.\n"
+ "Inno 16 Vorr. + tägl. rein. H. 7.2C_305\n"
+ "Inno 16 Vorr. + tägl. Rein. H.17-304\n"
+ "Inno 16 Vorr. + tägl. Rein. H. 17_304\n"
+ "InnoTrans 16 Reinigung CCB A/101 Vorr./Tägl.\n"
+ "InnoTrans 16 Reinigung FGSUED O/553 Reinigung Aufbau+Gl./Tägl.+Gl.\n"
+ "InnoTrans 16 Reinigung FGSUED O/240 Vorr./Tägl.\n"
+ "InnoTrans 16 Reinigung FGSUED O-240 Vorr./Tägl.\n"
+ "InnoTrans 16 Reinigung FGSUED O_240 Vorr./Tägl.\n"
+ "InnoTrans 16 Reinigung FGSUED Ost/240 Vorr./Tägl.\n"
+ "InnoTrans 16 Reinigung FGSUED T10/47 Reinigung nach Stundennachweis\n"
+ "InnoTrans 16 Reinigung FGSUED T10-47 Reinigung nach Stundennachweis\n"
+ "InnoTrans 16 Reinigung FGSUED T10_47 Reinigung nach Stundennachweis\n"
+ "Inno 16 - Storno H.22_808\n"
+ "trans 4.1-412 vor u tä\n"
+ "innotrans 16 reinig tä 21.-205\n"
+ "Inno 16 - Storno H. 22-808\n"
+ "Inno 16 - Storno H.22_808b\n"
+ "Inno 16 - Storno H. 22-808b\n"
+ "Inno 16 - Storno H.22_808\n"
+ "Inno 16 - Storno H.2.1_808\n"
+ "Inno 16 - Storno H.2.1_s808\n"
+ "Inno 16 - Storno H.2.1-S808\n"
+ "Inno 16 - Storno halle2.1_stand808\n"
+ "Inno 16 - Storno Halle2.1_Stand808\n"
+ "Inno 16 - Storno H2.1 S808\n"
+ "Inno 16 - Storno halle 2.1 stand 808\n"
+ "Inno 16 - Storno h2.1 s808\n"
+ "trans 4.1 412 vor u tä\n"
+ "innotrans 16 reinig tä 21. 205";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}