using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(c?)(h?)(e?)(r?)(r?)(y?)";
string input = @"berry";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}