re = /‘(?:(?![.,?!]’)[^’]){230,}(?=’)/m
str = 'this is a test ‘quote here quote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote \'Charles\'s horse\' herequote herequote herequote herequote herequote herequote herequote .herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote here’
this is a test ‘quote here quote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote \'Charles\'s horse\' herequote herequote herequote herequote herequote herequote herequote .herequote herequote!’ herequote herequote herequote herequote herequote herequote herequote herequote herequote herequote here’'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end