re = /^(?:#)([A-Za-z0-9_](?:(?:[A-Za-z0-9_]|(?:(?!))){0,28}(?:[A-Za-z0-9_]))?)((?: #)([A-Za-z0-9_](?:(?:[A-Za-z0-9_]|(?:\.(?!\.))){0,28}(?:[A-Za-z0-9_]))?))*/m
str = '#foo #bar
#foo,#bar
#foo#bar
#foo bar
#foo,bar'
# Print the match result
str.match(re) do |match|
puts match.to_s
end