# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\x1B\[(?:;?[0-9]{1,3})+[mGK]"
test_str = ("Summary [0m\n\n"
"Accounts:\n"
"Name Account ID Title\n"
"----------------------------------------------- ------------ -----------------------------------------------\n"
"[32maccount-accountType-gamma[0m [38;2;128;128;128m123456789012[0m account-accountType-gamma\n"
"[32maccount-accountType-e2e-gamma[0m [38;2;128;128;128m123456789012[0m account-accountType-e2e-gamma\n"
"Summary [0m\n\n"
"Accounts:\n"
"Name Account ID Title\n"
"---------------------------------------------- ------------ ----------------------------------------------\n"
"[32maccount-accountType-e2e-prod[0m [38;2;128;128;128m123456789012[0m account-accountType-e2e-prod\n"
"[32maccount-accountType-prod[0m [38;2;128;128;128m123456789012[0m account-accountType-prod")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.