re = /\b[a-zA-Z0-9 ]+\d+\b/im
str = 'Enter Room/Area^_^Area 100#_#Enter Grid^_^Grid2#_#Enter Level / Building^_^Building1#_#Enter Drawing^_^Drawing1#_#Enter Spec section^_^Spec2#_#Enter BOQ^_^BOQ1#_#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end