#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "LogL=\s*(-?\d+(?:\.\d+)?)"
Local $sString = " 7 LogL=-3695.47 S2= 9.0808 1891 df 2.263 0.2565 " & @CRLF & _
" 9 LogL= 2456.30 S2= 1.2789 1785 df 1.244 0.1354 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")