import re
regex = re.compile(r"^(2[0-4]\d|25[0-5]|1\d\d|\d\d?)\.(?1)\.(?1)\.(?1)$", flags=re.MULTILINE)
test_str = ("1.2.3.4\n"
"91.9.9.111\n"
"0.0.0.0\n"
"121.211.233.251\n"
"255.255.255.255\n\n"
"121.255.255.256\n"
"256.255.255.2\n"
"999.999.999.999\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")