$re = '/(?=.*:10:)(?=.*] 500 )/';
$str = '10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/signlangreasons HTTP/1.1" C9F41ED8235AADD69F997704FC55513A [-] 200 378 9ms Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/cases/statuses?actionType=service HTTP/1.1" E325D41D75BB121D44750BCE16C26A62 [-] 200 296 12ms Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/readreasons HTTP/1.1" C9F41ED8235AADD69F997704FC55513A [-] 200 452 15ms Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/ate/regions HTTP/1.1" 5B781DAF2A0E25E64BEC52ED4DC95A23 [-] 200 216 7ms Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.80 Safari/537.36
10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/translationreasons HTTP/1.1" C9F41ED8235AADD69F997704FC55513A [-] 200 260 18ms Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/capabilities?lang=RU HTTP/1.1" C9F41ED8235AADD69F997704FC55513A [-] 200 395 21ms Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/signreasons HTTP/1.1" C9F41ED8235AADD69F997704FC55513A [-] 200 446 22ms Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/members/types HTTP/1.1" 5B781DAF2A0E25E64BEC52ED4DC95A23 [-] 200 291 13ms Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/98.0.4758.80 Safari/537.36
10.0.2.16 [20/Dec/2023:10:56:22 +0300] "GET /notariat-ais/api/cases/billStatuses HTTP/1.1" E325D41D75BB121D44750BCE16C26A62 [-] 200 266 12ms Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/120.0.0.0 Safari/537.36
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);