$re = '/[A-Z]{3}\d{3}(?<!000)/';
$str = 'ABC001
ABC000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);