$re = '/^((?<name>[a-z0-9-_]+)(?<separator>[_\.#\/\\\\*\- ])){0,1}(?<number>\d+)\.(?<extension>[a-z]{3})$/mi';
$str = 'tot0_tutu_00001.tif
tot0.0001.tif
tot0#00001.tif
tot0/0001.tif
tot0\\00001.tif
tot0*0001.tif
00001.tif
tot0-tutu_0001.tif
tot0-tutu-00001.tif
tot0-tutu 000001.tif
tot0-tutu000001.tif';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);