$re = '/\'(.+)\'|n=(\d+)/m';
$str = 'Complete \'Function\' (Succeeded, Id=123456 Duration=247ms)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);