$re = '/^(Segunda|Terça|Quarta|Quinta|Sexta|Sábado|Domingo)(?:;(Segunda|Terça|Quarta|Quinta|Sexta|Sábado|Domingo))*$/m';
$str = 'Segunda;Terça
Segundaaa
Segunda;Terçaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);