#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^ksn-(?:a-(?:stat|p2p)|file|verdict|url|c?info)-geo\.kaspersky-labs\.com$"
Local $sString = "ksn-a-stat-geo.kaspersky-labs.com" & @CRLF & _
"ksn-a-p2p-geo.kaspersky-labs.com" & @CRLF & _
"ksn-file-geo.kaspersky-labs.com" & @CRLF & _
"ksn-verdict-geo.kaspersky-labs.com" & @CRLF & _
"ksn-url-geo.kaspersky-labs.com" & @CRLF & _
"ksn-info-geo.kaspersky-labs.com" & @CRLF & _
"ksn-cinfo-geo.kaspersky-labs.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")