import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([0-9]{2}\\s[A-Za-z]{3}\\s[0-9]{4}\\s[0-9]{2}:[0-9]{2}:[0-9]{2}(?:,[0-9]{3})?)\\s(?:\\^\\[\\[[0-9]{2}m)\\[([A-Za-z]+)\\](?:\\^\\[\\[m)\\s*([0-9a-fA-F\\-]*)\\s\\(([^\\)]+)\\)\\s((?:[a-zA-Z0-9-]+\\.)+[A-Za-z0-9$]+):\\s(?:\\s\\-\\s)?(?:(?!^[0-9]{2}\\s[A-Za-z]{3}\\s[0-9]{4}\\s[0-9]{2}:[0-9]{2}:[0-9]{2}).*(?:\\r?\\n)?)*";
final String string = "02 Jan 2018 05:25:56,546 ^[[32m[TEXT]^[[m aabb33-ddee33-54321 (host-1-usa-east) this.is.sample.log: service is responding normal\n"
+ "extra line 1\n"
+ "extra line 2\n"
+ "03 Jan 2018 08:25:56,546 ^[[32m[TEXT]^[[m aabb33-ddee33-54321 (host-1-usa-east) this.is.sample.log: service is responding normal";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}