re = /(?:(1(?(1)\1)).*?)+/m
str = '01
1001111
010011111
0100111110001110
0100111011001110
0100111110011110'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end