re = /^(?=.*(?:poverty|poor))(?=.*extreme)(?=.*(?:eradicat|end|reduc|alleviat)).+/m
str = 'Test poor and extreme and end
poor end test extreme
poor end test extrem'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end