$re = '/^[0+]+|[()-]/m';
$str = '001(123)12345
+1(123)12345
1-123-12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);