package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\x{2009}]`)
var str = `2 500`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}