#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9]+@.[a-z]+.[a-z]+$"
Local $sString = "kayush232@gmail.com" & @CRLF & _
"email@example.com" & @CRLF & _
"firstname.lastname@example.com" & @CRLF & _
"email@subdomain.example.com" & @CRLF & _
"firstname+lastname@example.com" & @CRLF & _
"email@123.123.123.123" & @CRLF & _
"email@[123.123.123.123]" & @CRLF & _
""email"@example.com" & @CRLF & _
"1234567890@example.com" & @CRLF & _
"email@example-one.com" & @CRLF & _
"_______@example.com" & @CRLF & _
"email@example.name" & @CRLF & _
"email@example.museum" & @CRLF & _
"email@example.co.jp" & @CRLF & _
"firstname-lastname@example.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")